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1 Introduction

The Portable Device Manager (PDM) provides a generic application for managing all 
portable devices, charging racks and desktop chargers on one or more sites.

The PDM makes it possible to edit parameters, update software in the devices and upload 
files. It can save parameters and software for individual sites in a database.

This document is intended as a guide for installation, maintenance and troubleshooting 
purposes and is relevant for:

• Installation and parameter setup.

• Device administration and PDM daily use.

1.1 Abbreviations and Glossary

Contacts The name of the phonebook in a handset.

CSV file Comma Separated Value: 
A file with data, where values in each row are separated by a 
delimiter, which can be a comma, a semicolon or a tab.

DECT Location Location solution based on DECT technology.

Device Can be a DECT or VoWiFi handset, an alarm transmitter, a 
pager, a Location device or a charger developed to work 
together with the PDM.

EAP Extensible Authentication Protocol

GUI Graphical User Interface.

JRE Sun Java Runtime Environment.

Language file Language file for portable devices or PDM.

License information file A file containing license keys for devices. The file can be 
exported from the License Web and imported to WinPDM.

License key The unique license key for a specific device with a specific 
functionality.

Messenger Product license for Messaging solutions for handset.

Number Settings for the complete set of parameters of a single 
device, tied to a specific identity.

Parameter definition file Defines the parameters for a portable device model, for 
example a handset, alarm transmitter etc.

PDM Portable Device Manager.
An application, running on a PC, for management of 
portable devices, charging racks, etc.

Package file A file including different types of files, such as software files, 
parameter definition files or template files.

Portable Used synonymously with portable device

Portable device Cordless handset, alarm transmitters/transceivers etc.

Product information file A file containing information needed for licensing and 
upgrade of a device. The file can be exported from WinPDM 
and imported to the License web.

RS232 Industry standard serial communication protocol.

Site Contains information of devices and Numbers.
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Software file A file including software for devices.

Talker Ascom name for handsets primarily used for pure telephony.

USB Universal Serial Bus:
A serial bus standard to interface devices, for example 
connect computer peripherals such as mice, keyboards, 
scanners etc.

WiFi WiFi stands for Wireless Fidelity and is a term developed by 
the Wi-Fi Alliance® to describe wireless local area network 
(WLAN) products that are based on the Institute of Electrical 
and Electronics Engineers' (IEEE) 802.11 standards. Today, 
most people use WiFi as a reference to wireless connectivity.

VoIP Voice over Internet Protocol

VoWiFi Voice over Wireless Fidelity: a wireless version of VoIP and 
refers to IEEE 802.11a, 802.11b or 802.11g network.
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1.2 How to Use this Document

For a basic description on how to work with the PDM, see 1.5 PDM description on page 5.

1.2.1 Installation and Configuration

These tasks are intended for installation and configuration.

In order to simplify, for example an installation on a site, use the following steps.

1 Install the PDM on your computer, see 2.1 Software Installation on page 6.

2 Open and configure the PDM, see 2.2 Software Configuration on page 6.

3 Create a template with settings common for all devices of a certain device type at 
the site, see 3.8.1 Create a Parameter Template on page 30.

During system setup it is likely that the personnel doing the installation and configuration 
continues with the Administration tasks below to make the system fully functioning.

1.2.2 Administration

These tasks are intended for administration. This is the recommended order.

1 Create new Numbers, see 3.6.1 Create New Numbers on page 18, and run the 
template on the Number(s), see 3.6.5 Run a Template to set Parameter Values on 
page 23.

2 Make individual settings for each Number. See 3.6.4 Edit Parameters on page 22.

3 If applicable, switch on the devices.

4 Connect the devices, one after the other, and associate them with the Numbers, 
see 3.6.6 Associate a Number with a Device on page 23. Different devices have 
different ways of connecting.

Note: The very first time a device is connected to the USB port, the Found New 
Hardware wizard displays (not for all computers). Do the following: Select “No, not 
this time” and click “Next” (twice).

More tasks are described in this document, such as how to import different types of files.
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1.3 Technical Solution

The PDM software is installed on a PC running Windows XP® Professional or Windows 
Vista® Business, see 1.4 Requirements. The device is then connected to the PC running 
the PDM software, either via the USB port or the COM port (depends on device model). 
The device must be set up to handle this connection according to the instructions in the 
user manual for the device.

Note: Only one device at a time can be connected to PDM Windows Version. A charger 
can hold one on more devices though.

Figure 1. Connection to the PDM depends on device type.

Parameters can be edited for a single device and then sent to the device, but if many 
devices are to be updated with new parameter settings it is also possible to create a 
parameter template and run the template on each Number. 

Parameters can be uploaded from a connected device, edited and sent to the device 
again. If the PDM shall store parameter settings in the site database or not, is selectable.

Devices can be upgraded with new software. A text and a status bar indicates that the 
connected device is being updated with the new software.

1.4 Requirements

• Computer

- PC with Windows XP® Professional, Service Pack 2 (SP2) or 
Windows Vista® Business.

- Sun Java Runtime Environment (JRE) version 6 or higher.
- Acrobat Reader 4.0 or higher.
- Connection to device is dependent on device type, see respective device manual: 

RS232 Serial port, or 
USB port. USB 1.1 required, USB 2.0 supported.

Figure 1. 

USB port

00
1

PDM

Advanced desktop charger/ 
USB Programming device 
(dependent on device)

RS232
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1.5 PDM description

1.5.1 PDM terminology

This section gives a brief description of the basic terminology in PDM.

• Device; can be a charger, a location device, or a portable device that can be connected 
to PDM.

• Number; the complete settings for a single device. Also chargers have a Number.

• Template; general settings for a specific device type. A template can be applied to 
several Numbers of the same device type.

• License; licensed functionality for a device.

• Tabs; in the PDM there are four different views, or tabs. In these tabs, the information 
for devices, Numbers, templates and licenses are shown.

• Parameter definition file; a file including all possible settings for a certain device type. 
Templates are created from parameter definition files.

• Software; is the software used in devices. The device software can be updated via 
PDM.

• Version; parameter definition files and device software are indicated by versions.

• Package file; a file that can contain other files, such as parameter definition files, 
software files and template files.

• Importing; different types of files can be imported.

• Associate; before being able to synchronize parameters between PDM and devices, it is 
necessary to associate a Number with the device. Association includes all parameters. If 
it exists on that device type, it also includes Contacts.

• Assign; it is possible to assign a Number to a device that has not yet been assigned a 
Number in the Device Manager. Assign includes only the parameters defining the 
Number.

1.5.2 PDM usage

This section gives a short description to give a basic understanding on how to use the PDM 
with devices.

• Import a parameter definition file of the corresponding device type to PDM.

• Create a template from the parameter definition file.

• Add a device to PDM.

• Create a new Number for the corresponding device type.

• Associate the Number with the device.

See chapters 3 Operation on page 9 and 4 Administration on page 47, for a detailed 
description.
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2 Installation and Configuration

2.1 Software Installation

This section describes the installation procedure when installing from a CD.

Note: Do not connect the hardware to the computer before installation.

1 Close all running programs.

2 Insert the PDM installation CD.

3 Follow the instructions given by the setup program.

If the setup program does not start automatically, it is possible to do one of the following:

• Right-click on the CD-drive in a file browser and select “Install”.

• Double-click on the SETUP.EXE file on the CD in a file browser.

2.2 Software Configuration

This chapter includes settings for:

• Initial startup

• Optional COM port settings

• Site setup

• Definition files

• Language

2.2.1 Initial startup

In the Start menu, select All Programs > Ascom WinPDM > Ascom WinPDM.

Note: Windows Firewall may alert you of “MwpCSI”, “PMServer”, “UspCSI”, “CuspCSI” 
and “CuspSerialCSI”.

The first time PDM is started, the Create site dialogue appears. See 3.5.1 Create a New 
Site on page 16.
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2.2.2 Optional COM port settings

If only the USB connection will be used, the settings in this section are not needed. These 
settings need to be done only if a COM port will be used.

1 In the Options menu, select “Preferences”.

2 Select the COM port to be used for connecting devices to the PC and click “OK”.

Figure 2. The Preferences dialogue.

2.2.3 Site setup

1 In the File menu, select “Site management”.

Figure 3. The Site management dialogue.

2 Click “New”.

Figure 2. 

Figure 3. 
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3 In the Create site dialogue, enter a site name and a site description (optional) in 
their respective fields and click “OK”.

Figure 4. The Create Site dialogue.

Note: One site needs to be present for the PDM to be able to run.

4 Click “Close”.

2.2.4 Definition files

Before starting to use templates in PDM, definition files need to be imported.

How to import parameter definition files is described in 3.10.2 Import a Package File on 
page 38 and 3.10.3 Import Parameter Definition files on page 39.

For general information about file handling, see 3.10 File management on page 38.

2.2.5 Language settings for PDM

Note: For adding a new language to a device, see 3.10.5 Import Language files for 
Devices on page 41 and 3.10.7 Upload a Language to Devices on page 43.

It is possible to select the language to be used in the menues in PDM by importing a 
language file with the file extension *.xml. 

The default language file (.xml) is copied to your installation directory at installation: 
C:\Program Files\Ascom\WinPDM\Client\default-translations.xml. 
This file can be copied and edited to create a new language and can then be imported 
from the Select language dialogue, see figure 5.

1 In the Options menu, select “Select language”.

Figure 5. The Select language dialogue

2 Click the “Import...” button. In the Import files window, find and select the 
language file (.xml) to be imported and click “Open”.

3 In the Available languages: drop-down list, select which language to use.

4 Click “OK”.

Figure 4. 

Figure 5. 
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3 Operation

3.1 The PDM GUI

3.1.1 PDM Window

The PDM window consists of three areas: Menu, Toolbar and Work Area. The Toolbar has 
four tabs: Devices, Numbers, Templates and Licenses. When one of these tabs is selected 
the available device types are shown in the left hand pane of the work area. The right 
hand pane shows the devices, Numbers or templates that have already been configured.

Figure 6. PDM Window Area.

Search Field

In the upper part of the Work area there are search fields where different search criteria 
can be selected depending on which tab that is displayed. The search field is colour coded 
green or red depending on if there are possible matches to the search criteria or not.

Sort the List

By default the lists are sorted by the first column. To sort the list by any other column, click 
the column heading. To reverse the sort order, click the column heading again. The sort 
order is indicated by an up or down arrow in the column heading. Secondary sorting order 
can be done by pressing "Ctrl" and clicking the column heading.

Filter the List

By default the list in each tab shows all available Devices, Numbers or Templates. It is 
possible to filter the list by selecting a device type in left pane.
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3.1.2 Colour coding

General colour coding

• If the version number is shown in red, PDM has found no parameter definition files 
supporting that device type.

• If the version number is shown in dark red, the parameter definition file is compatible, 
but does not have exactly the same version as the device.

Colour coding for parameter and template editing

In the parameter and template editing windows, the following colour coding is used:

3.1.3 Tabs

Devices Tab

The view shows all devices configured at the site in a detailed list. The following 
information can be displayed (see also figure 7 on page 11):

• Device ID – the unique identifier of the device.
• Device type – the device model.
• Software version – the version of the software in the device. 
• Parameter version – the version of the parameters in the Number
• Upgrade status1 – might show one of the following symbols:

• Online – shows if the device is connected to the PC running PDM. The  
symbol indicates a connected device.

• Latest number - shows the latest known Number for a device.

Colour Context Description

Black General Normal

Dark blue For templates and parameter 
editing

Parameter has been edited during the 
current session

Purple For templates The parameter is included in the 
template (checked)

Red For templates and parameter 
editing

Value not valid

Turqoise For templates and parameter 
editing

The value differs from the default value

 – new software upgrade is in progress.
It is also possible to see a progress bar when the device is being 
upgraded.

 – software upgrade Pending, Request sent, or Accepted (a green arrow).

 – software upgrade Scheduled or Retrying.

 – the last upgrade Failed or Aborted (a red broken arrow).

1.See also Software Upgrade Fails on page 50.
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Figure 7. The Devices tab showing a list of devices in a system.

Numbers Tab

The view shows all Numbers configured at the site in a detailed list. The following 
information can be displayed:

• Number – the unique identifier of the Number. The identifier is unique for that 
device type.

• Device type – the device model the Number is intended for.
• Parameter version – shows the version of the parameters in the Number.
• Device ID – the unique identifier of the device that the Number is associated to.
• Online – shows if the device the Number is uploaded to is connected to the PC 

running PDM. The  symbol indicates a connected device.
• Status – shows the parameter synchronization status. A Number can also be 

queued for synchronization. Several different indications are used, for example 
Synchronizing, Sync queued, Save queued, Synchronized, etc. 
When the Number is offline, the database status is shown; Synchronized or Not 
synched.

• Saved – shows if the Number’s parameters have been stored in the database. 
The  symbol indicates that the parameters have been stored.

• Last run template - indicates which template that was last run for that Number.

Figure 8. The Numbers tab showing a list of Numbers in a system.
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Templates Tab

The view shows all templates configured at the site in a detailed list. The following 
information can be displayed:

• Name – the name of the template.
• Device type – the portable device model.
• Parameter version – shows the parameter version.

Figure 9. The Templates tab showing a list of templates in a system.
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Licenses Tab

The view shows all devices configured at the site in a detailed list. The following columns 
are displayed:

• Device ID – the unique identifier of the device
• Device type – the device model
• Online – shows if the device is connected to the Device Manager. The   

symbol indicates that the device is online
• Serial number – the number identifying the device hardware
• Number – the unique identifier of the Number. The identifier is unique for that 

device type.
• Software version – shows the version of the software in the device
• Status – shows the license synchronization status. 

Examples of status that can be shown are.  
"Sending" means that WinPDM is sending license information to the device. 
"Server failure" means that there is some kind of error with the communication 
between WinPDM and the license server. 
"Needs update" -  An attempt to move a license from one handset to another 
has been made, but the latest license does not exist in the handset.

Figure 10. The Licenses tab showing a list of devices.
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3.2 The Device Wizard

When a device without a number is connected to the PDM, the Device Wizard window 
appears.

Figure 11. Device Wizard

In the Device Wizard, there are four choices:

• Associate with Number, see also 3.6.6 Associate a Number with a Device on page 23.

• Run template, see also 3.6.5 Run a Template to set Parameter Values on page 23.

• Edit parameters, see also 3.6.4 Edit Parameters on page 22.

• Do nothing

3.3 The New Number Wizard

When a new device with a not saved Number is connected, the New Number Wizard 
window appears.

Figure 12. The New Number Wizard

Figure 6. 
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In the New Number Wizard, there are four choices:

• Store in database

• Edit parameters, see also 3.6.4 Edit Parameters on page 22.

• Run template, see also 3.6.5 Run a Template to set Parameter Values on page 23.

• Do nothing

3.4 Open the PDM

1 In the Start menu, select All Programs > Ascom WinPDM > Ascom WinPDM.

2 The view of the last used Site opens. To open another site, see 3.5.2 Open a Site on 
page 16.
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3.5 Site Management

By creating a Site for each customer installation, devices, software and licenses can be 
managed for that site. The settings are saved in a database.

Note: There is a subtle but important difference between loading and opening a site. 
When a site is opened, the Site management dialogue closes and it is possible to start 
working with the devices in the site; when a site is loaded, the Site management dialogue 
stays open, making it possible to continue with site management tasks, such as creating 
and deleting sites.

Figure 13. Site Management window.

3.5.1 Create a New Site

1 In the File menu, select “Site management”.

2 Click “New...”.

3 Enter a name for the site and a description (optional) and click “OK”.

4 Click “Close”.

3.5.2 Open a Site

1 In the File menu, select “Site management”.

2 Select the site to be opened and click “Open”.

3.5.3 Load a Site

1 In the File menu, select “Site management”.

2 Select the site to be loaded.

3 Click “Load”. The view in the main window changes to the newly opened site.

4 Click “Close”.

Figure 7. 
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3.5.4 Delete a Site

1 In the File menu, select “Site management”.

2 Make sure that the site to be deleted is not currently active. If it is active, load 
another site (see 3.5.3 Load a Site).

If there is only one site remaining, it cannot be deleted.

3 Select the site to be deleted and click “Delete”.

4 In the Delete Site dialogue, click “Yes”.

5 Click “Close”.

3.5.5 Import a Site

When importing a site, numbers with parameters and devices are imported. Templates, 
software and definition files are not imported.

1 In the File menu, select “Site Management”.

2 Click “Import...”.

3 Find and select the Site file (.ste) to be imported. Click “Open”.

Figure 14. Input dialogue.

4 In the Input dialogue, enter a name for the site and click “OK”. 

5 Click “Close”

3.5.6 Export a Site

1 In the File menu, select “Site Management”.

2 Select the site to be exported and click “Export...”.

3 Enter a file name of the site (.ste) and where to save the file. Click “Save”.

4 Click “Close”
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3.6 Numbers

3.6.1 Create New Numbers

1 Select the “Numbers” tab.

2 In the Number menu, select “New...”. Alternatively, right-click in the Numbers list 
and select “New...”.

3 In the Device type drop-down list, select device type.

4 In the Parameter version drop-down list, select the parameter version.

5 In the Template drop-down list, select which template to run on the Number. This is 
optional and therefore “None” can be selected.

6 In the Prefix field, enter the Number’s prefix (if needed).

7 Select one of the following options:

• To create a single Number, select the Single option and enter the call number. 
Click “OK”.

• To create a range of Numbers, select the Range option. Enter the start call 
number, end call number, and click “OK”.

Note: The maximum range that can be added at a time is 100 Numbers.

3.6.2 Save a Number to database

The Number of an online device can be saved to the database.

1 Select the Numbers tab.

2 Select the Number.

3 In the Number menu, select Save, or right-click the Number and select Save.

3.6.3 Manage Certificate for a WLAN Device

Note: This functions is applicable for WLAN handsets only. In addition, the handset must 
be online in PDM.

Certificate(s) is used for authorizing a WLAN handset to access a WLAN system using 
Extensible Authentication Protocol (EAP). 

There are two types of certificates: Root certificate and client certificate. 

The WLAN handset using the root certificate to control if the WLAN system is trusted. If 
the system is trusted, the handset send its client certificate to show that it is authorized to 
access and logon the system.

The root certificate contains a public key and can be downloaded to the handset via 
Device Manager in the IMS2 or via WinPDM. The client certificate contains both a public 
key and a private key and can only be downloaded to the handset via the WinPDM.

The following must be done to be able to use certificates:

• Import certificates to handset, see Edit Certificate.

• Select which client certificate to use by setting a EAP client certificate parameter, see 
the Configuration Manual for the WLAN handset.

Edit Certificate

1 Select the “Numbers” tab.

2 In the Number menu, select “Edit certificates”. Alternatively, right-click in the 
Numbers list and select “Edit certificates”.
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A Edit certificates window opens, see figure 15. 

Figure 15. Edit Root Certificate tab

Figure 16. Edit Client certificate tab.

The following information is displayed:

• The number of the device

• The device type

• The parameter version

• The online status of the device

• Imported certificates (if any)

3 Root certificate and client certificate can be edited. If needed, click the “Root” tab 
or the “Client” tab for switchting to the corresponding certificate view.

4 Click the corresponding “Edit“ button to edit the certificate.

5 Locate the certificate file and click “Open“.

6 If the certificate is passport protected, an Enter Password dialouge appears. Enter 
the password and then click “OK”.

A Confirm Certificate windows appears, see figure 17 on page 20. The following 
information is displayed:

• The algorithm of the certificate

• The validity status of the certificate

• The validity period of the certificate

• The issuer of the certificate

• The authorized users of certificate (issued to).
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Figure 17. Confirm Certificate Window

7 Import the certificate to the device by clicking “Yes“.

If needed, repeat step 3 - 6 for editing additional certificates.

Additional settings are required for selecting which certificate the handset shall use. See 
Configuration Manual, Ascom i62 VoWifi Handset, TD 92675GB.

View Certificate Details

1 Select the “Numbers” tab.

2 In the Number menu, select “Edit certificates”. Alternatively, right-click in the 
Numbers list and select “Edit certificates”.

3 If needed, click the “Root” tab or the “Client” tab for switchting to the 
corresponding certificate view.

4 Select the certificate to view by clicking the corresponding “Details“ button.

A Certificate details windows appears, see figure 18. The following information is 
displayed:

• The algorithm of the certificate

• The validity status of the certificate

• The validity period of the certificate

• The issuer of the certificate

• The authorized users of certificate (issued to)
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Figure 18. Certificate Details Window

Remove Certificate

1 Select the “Numbers” tab.

2 In the Number menu, select “Edit certificates”. Alternatively, right-click in the 
Numbers list and select “Edit certificates”.

3 If needed, click the “Root” tab or the “Client” tab for switchting to the 
corresponding certificate view.

4 Select the certificate to remove by clicking the corresponding “Remove“ button.

5 A Remove certificate window appears. Click “Yes“ to remove the selected 
certificate.

The certficates are now removed to the handset. Additional settings are required for 
selecting which certificate the handset shall use (if any). See Configuration Manual, Ascom 
i62 VoWifi Handset, TD 92675GB.
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3.6.4 Edit Parameters

The Edit Parameters dialogue shows the set of parameters for the Device/Number. The 
parameters are organized in a tree structure in the left pane, with the parameters in the 
current node in the right pane. Clicking the  icon will give a short description of 
selected parameter.

Note: If Edit parameters was selected in the Device Wizard window (see figure 11 on page 
14) or in the New Number Wizard window (see figure 12 on page 14), continue from step 
4.

1 Select the “Numbers” tab.

2 Select the Number.

3 In the Number menu, select “Edit”. Alternatively, right-click and choose “Edit”, or 
double-click the Number. 

4 In the left pane, select the parameters.

5 In the Value column, make your changes

When a parameter has been edited, the node in the left pane changes to a blue 
colour.

6 Click “OK” to save your changes. Click “Cancel” to undo all parameter changes..

Figure 19. Editing parameters in the PDM GUI.

Note: When you save the parameters, they are automatically sent to the device if it is 
connected.

Figure 8. 
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3.6.5 Run a Template to set Parameter Values

If a template has been created for a device type, it can be used to set the parameter values 
for a range of devices, or a single device.

Note: If Run template was selected in the Device Wizard window (see figure 11 on page 
14) or in the New Number Wizard window (see figure 12 on page 14), continue from step 
4.

1 Select the “Numbers” tab.

2 Select the Number or Numbers you wish to run the template on.

3 In the Number menu, select “Run template...”. Alternatively, right-click the Number 
in the Number list and select “Run template...” from the menu that appears. 

Figure 20. Selected template to run on one or several Numbers.

4 Select a template from the Template list and click “OK”.

3.6.6 Associate a Number with a Device

Before being able to synchronize parameters between PDM and devices, it is necessary to 
associate a Number with a device. It is possible to enter several Device IDs in advance and 
to associate them with a Number at a later moment.

See also 3.7.6 Assign a Number on page 28

Note: If Associate with number was selected in the Device Wizard window (see figure 11 
on page 14), continue from step 3.

1 Select the “Numbers” tab.

2 In the Number menu, select “Associate with device...”.

Figure 9. 
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Figure 21. Associate number dialogue.

3 Select the device you want to associate with in the list and click “OK”.

If the selected device is online, it will immediately be updated with the selected Number. If 
the selected device is not online, it will be updated the next time it is online.

It is possible to associate several Numbers with several devices simultaneously.

3.6.7 Delete a Number in the Site Database

1 Select the “Numbers” tab.

2 Select the Number you want to delete.

3 In the Number menu, select “Delete”. Alternatively, right-click the Number in the 
Number list and select “Delete” from the menu that appears.

4 In the Delete Numbers dialogue, click “Yes”.

Note: If an online device is deleted it will stay in the list as online but not saved.

Figure 10. 
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3.6.8 Rename a Number

1 Select the "Numbers" tab.

2 Select the Number you want to rename.

3 In the Number menu, select "Rename...". Alternatively, right-click the Number in 
the Number list and select “Rename...” from the menu that appears.

4 In the Rename number dialogue, enter a new prefix (optional) and a new Number 
and click "OK".

3.6.9 Copy a Number

1 Select the "Numbers" tab.

2 Select the Number you want to copy.

3 In the Number menu, select "Copy...". Alternatively, right-click the Number in the 
Number list and select “Copy...” from the menu that appears.

4 In the Copy number dialogue, enter a new prefix (optional) and a new Number and 
click "OK".

3.6.10 Import Contacts

Note: This feature is not available in all versions of PDM. In addition, the number for the 
handset must be saved, see 3.6.2 Save a Number to database on page 18.

Import Contacts From File

A file containing contacts can be imported to PDM and synchronized with a handset. This 
feature enables transfer of contacts from older handsets.

The format of the file is a TAB or semicolon separated text file with two values per row; 
name and number, each value consisting of up to 24 characters or digits.

1 In PDM, select the Numbers tab.

2 Select a number.

3 In the Number menu, select “Import contacts” > “From file”. Alternatively, right-
click the Number in the Number list and select “Import contacts”> “From file” from 
the menu that appears.

4 Find and select a file containing contacts (.txt or .csv). Click “Open”.

The contacts in the imported file are synchronized with the handset.

Import Contacts From Number

This feature enables transfer of contacts from one handset to another handset which 
numbers that have been saved in the PDM.

1 In PDM, select the Numbers tab.

2 Select a number.

3 In the Number menu, select “Import contacts” > “From number”. Alternatively, 
right-click the Number in the Number list and select “Import contacts”> “From 
number” from the menu that appears.

4 Select a number.

5 Click “OK”.

The contacts are now imported to the handset.
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3.7 Devices

A device can be a DECT or VoWiFi handset, an alarm transmitter or a pager developed to 
work together with the PDM. See the user manual for respective device.

All work with devices is performed from the “Devices” view.

• Devices can be added to a site by connecting the device to the PC.

• It is possible to transfer the information for a Number from one device to a new device.

• Devices can be reset to factory settings.

• Devices can be updated with new software.
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3.7.1 Add Devices to a Site

Before connecting a device to the PDM, make sure the connection is set up according to 
the instructions in the device´s Configuration Manual. If such a manual does not exist the 
instructions can be found in the device´s User Manual, or in some case the Installation 
Guide.

If a range of new devices are to be added to a site, the easiest way is to: 

1 Create a template with all common parameter settings for the site. See 3.8.1 
Create a Parameter Template on page 30.

2 Add a range of Numbers and run the template. See 3.6.1 Create New Numbers on 
page 18 and 3.6.5 Run a Template to set Parameter Values on page 23.

3 Edit the parameters and change individual settings. See 3.6.4 Edit Parameters on 
page 22.

4 Connect the physical devices, one after the other, and associate them with the 
Numbers in the site database. See 3.6.6 Associate a Number with a Device on page 
23.

A single device can be added in the same way.

Note: It is not possible to change model of a device already added to the site. Instead, a 
new device of the desired model must be added to the site.

3.7.2 Synchronize a Device

When a device is connected, it is synchronized with the associated Number in the PDM.

When a device is being synchronized, parameters that have been changed in the device 
are uploaded to the PDM, and parameters that have been changed in the PDM are sent to 
the device. If a parameter has been changed in both the device and the PDM, the setting 
made in the PDM will take precedence.

1 Select the “Numbers” tab.

2 Connect a device to the computer running the PDM. If the Number is saved, and it 
has a parameter definition, the device is automatically synchronized. 

3.7.3 Delete a Device in the Site Database

1 Select the “Devices” tab.

2 Select the device you want to delete.

3 In the Device menu, select “Delete”, or right-click the device and select “Delete”.

4 In the Delete Device dialogue, click “Yes”.

Note: You cannot delete a device that is online.
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3.7.4 Replace a Device

If a device shall be replaced with a new device, it is possible to transfer its associated 
Number to a new device. The new device must be of the same model as the old one.

1 If the device to be replaced is still working, make sure that it is synchronized.

2 Connect the new device to the PDM.

3 Associate the new device to the Number associated to the old device according to 
the instructions in 3.6.6 Associate a Number with a Device on page 23. The 
Number will no longer be associated to the old device.

3.7.5 Create new Device

It is possible to enter several new Device IDs in advance into PDM for later association.

In order to simplify input when handling many devices, it is possible to use a bar code 
reader. The bar code reader should send a carriage return after each item, but it is not 
necessary. If carriage return is not sent, it is necessary to click “Create” after each read 
item.

1 Select the “Devices” tab.

2 In the Device menu, select “Add device”.

Figure 22. The Create devices dialogue.

3 Select device type and parameter version.

4 Enter a Device ID for the device, manually or by using a bar code reader.

5 The “Continuous registration” checkbox can be used to select whether the “Create 
devices” dialogue shall close after clicking “Create” or if it shall still be open.

6 Click “Create”.

7 Repeat 4 to 6 if more devices are to be created, otherwise click "Close".

3.7.6 Assign a Number

It is possible to assign a Number to a device that has not yet been assigned a Number in 
PDM. This feature can be used if parameters have been changed on the device prior to 
connection to PDM.

Assign shall not be done on a device that already has a Number.

See also 3.6.6 Associate a Number with a Device on page 23

1 Select the “Devices” tab.

2 Select the device you want to assign a Number for.

Figure 11. 
01 February 2010 / Ver. H 28



TD 92325GB
Installation and Operation Manual
Portable Device Manager (PDM), Windows version
3 In the Devices menu, select “Assign number”.

4 In the Assign Number to device dialogue, enter a new prefix (optional) and a new 
Number. Click “OK”.

Figure 23. The Assign number to device dialogue.

3.7.7 Factory Reset

Factory reset means that the device parameters will be set to factory default settings. The 
Number in the database that is associated with the device will not be affected.

Note: The device must be online.

1 Select the “Devices” tab.

2 Select device(s) to be reset.

3 In the Device menu, click “Factory reset”. Alternatively, right-click the device and 
select “Factory reset”.

4 Click “Yes”.

3.7.8 Device Properties

To get a summary of the properties of a device:

1 Select the “Devices” tab.

2 Select device.

3 In the Device menu, click “Properties”. Alternatively, right-click the device and 
select “Properties”.

The following information is displayed (depending on PDM version):

• Device ID

• Device type

• Parameter version

• Software version

• Last known number

• Online status

• File upload information

Figure 12. 
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3.8 Templates

Templates are a collection of user defined parameter values. These templates can be used 
to create common settings to be used on several devices of a certain device type.

Note: Templates created in one site are also selectable in the other sites used in PDM.

3.8.1 Create a Parameter Template

1 Select the “Templates” tab.

2 In the Template menu, select “New”. 

Figure 24. Create Template dialogue

3 Select device type and parameter version, enter a name for the template, and click 
“OK”. The view switches to the Edit Template parameter view.

Note: If you cannot find your device type and/or parameter version in the list, PDM needs 
to be updated with new parameter definition files, see 3.10.3 Import Parameter Definition 
files on page 39.

Figure 25. Edit Template parameter view

Figure 13. 

Figure 14. 
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4 Select the parameters you want to be saved in the template by selecting the 
checkbox to the left of each parameter. Change the parameters to the desired 
values.

5 Click “OK”.

3.8.2 Create a Parameter Template from a Number

It is also possible to create a template from a portable device in the PDM.

1 Select the “Numbers” tab.

2 Mark the Number you want to use.

3 Right-click the Number and select “Use as template...”.

4 Enter a name for the template.

5 Click “OK”. The Edit template dialogue opens.

6 Continue with 4 to 5 in 3.8.1 Create a Parameter Template on page 30.

Note: When the Edit template window is opened from the "Use as template" command, 
an extra drop-down list, "Select" is shown in the bottom left corner. This setting decides 
which parameters that shall be copied from the Number. If "All parameters" is selected, 
the synchronization time will be longer.

It is also possible to create a template from a portable that is online but not stored in the 
database. The template will contain all parameters for the device except for those that are 
Number specific.

3.8.3 Rename a template

1 Select the "Templates" tab.

2 Select the template you want to rename.

3 In the Template menu, select "Rename...", or right-click and select "Rename...".

4 In the Rename template dialogue, enter a new name and click “OK”.

3.8.4 Copy a template

1 Select the "Templates" tab.

2 Select the template you want to copy.

3 In the Template menu, select "Copy..." or right-click and select "Copy...".

4 In the Copy template dialogue, enter a new name and click “OK”.

3.8.5 Edit a template

1 Select the "Templates" tab.

2 Select the template you want to edit.

3 In the Template menu, select "Edit..." or right-click and select "Edit...".

4 In the Edit template window, edit the parameters and click “OK”.
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3.8.6 Delete a template

1 Select the "Templates" tab.

2 Select the template you want to delete.

3 In the Template menu, select "Delete", or right-click and select "Delete", or press 
the Delete button.

4 In the Delete Template dialogue, click "Yes".

3.8.7 Upgrade a template

1 Select the "Templates" tab.

2 Select the template you want to upgrade.

3 In the Template menu, select "Upgrade..." or right-click and select "Upgrade...".

Figure 26. The Upgrade template dialogue.

4 Select the parameter version to upgrade to and click "OK".

Figure 15. 
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3.8.8 Apply a template

1 Select the "Templates" tab.

2 Select the template you want to use.

3 In the Template menu, select "Apply to..." or right-click and select "Apply to...".

Figure 27. The Apply template window.

4 Select Number(s) to apply the template on and click "OK".

Figure 16. 
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3.9 Licenses

This section describes the device licensing features that can be done using the WinPDM. 
An overview of the device licensing concept is described in Function Description, Product 
Licensing Overview, TD 92677GB.

In WinPDM, device licensing offers a possibility to view, manage and upgrade licenses of 
devices. In the Licenses tab, devices are listed. If a device is selected in the list, the status of 
the license options for the selected device is displayed.

Note that some tasks include using the License Web and the details of how to work with 
the license web are not described here.

The following features are described:

• Upgrade licenses, "Import" and "Export"

• Manual synchronization of licensing information, "Refresh"

• View license options

• Filter license options

The following licensing features are not done with the WinPDM and are therefore not 
described is this document:

• How to work with the license web

• How to purchase licenses

• Manual license upgrade using handset

The license of a handset can be upgraded to a license of a higher variant level, for example 
from a d62 Talker license to a d62 Messenger license. Depending on the variant used, 
additional license options may be available.

Note: A handset can be re-licensed a limited number of times. For the d81, d62 and d41 
handsets it is limited to 99 times.

3.9.1 License Upgrade alternatives

License upgrade includes using the license web which is described in Function Description, 
Product Licensing Overview, TD 92677GB.

These are the alternatives for upgrading licenses on devices:

• Automatic license upgrade 
Used when the WinPDM has an internet connection to the license server, see 3.9.2 
Automatic license upgrade.

• licenselicense upgrade using export/import 
Used when the WinPDM does not have an internet connection, see 3.9.3 Export and 
Import Licensing information.

• Manual license upgrade 
Used to enter the license key manually in the handset, see the configuration manual 
for the corresponding handset. In this case, the WinPDM is not used.
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3.9.2 Automatic license upgrade

Note: This feature requires an internet connection.

The first time a device logs in to the Device Manager, the WinPDM asks the license server 
if any licenses are available for the device. When the device logs in at a later time, there is 
no automatic check for licenses. If changes have been made, a manual upgrade must be 
done by selecting Refresh, see 3.9.6 Refresh on page 37.

Automatic license upgrade is a way of upgrading automatically to the correct license for a 
device. In order to get a purchased license for a device, a connection with the license 
server is made. The WinPDM automatically gets device licensing information from the 
device, sends it to the license server which returns a license key that the WinPDM sends to 
the device. The device upgrades and the correct license information is shown in the 
WinPDM and the device.

Warning: If the Number for the upgraded handset is also used for another handset within 
the same family, there can be a conflict when upgrading licenses. For example, if a d62 
Talker is upgraded to a d62 Messenger, and a d62 Messenger with that number already 
exists, there will be a conflict. In this case, the settings in the Device Manager will take 
precedence over the settings in the device, i.e. the d62 Messenger settings will be used for 
both handsets.

3.9.3 Export and Import Licensing information

In order to upgrade licenses on devices when the WinPDM does not have an internet 
connection to the license server, the following is done:

• The information needed for licensing of a device is exported from the Device Manager 
to a file, see Export Licensing information on page 35.

• The file determines which additional license options that are available for the device. It 
can also be used to view the current license options of the device in the license web.

• From the license web, a license file containing the license keys for the device is 
generated

• The license file is imported to the Device Manager, see Import licenses on page 36

• The Device Manager communicates the license key (included in the license file) to the 
device

• The device upgrades according to the license options

Export Licensing information

The information needed for licensing of a device can be exported to a product information 
file. This file can be used to generate licenses for the device.

1 Select the Licenses tab.

2 Select the device(s) that shall be exported.

3 In the License menu, select "Export". Enter a name for the file and click "Save".

See Function Description, Product Licensing Overview, TD 92677GB for a description of 
how to generate licenses.
01 February 2010 / Ver. H 35



TD 92325GB
Installation and Operation Manual
Portable Device Manager (PDM), Windows version
Import licenses

License files are used for upgrading devices with licenses. A license file can be imported to 
the Device Manager.

See Function Description, Product Licensing Overview, TD 92677GB for a description of 
how  license files are generated.

1 In the File menu, select “Import” > "Licenses...”.

2 Select the license file(s) to be imported (*.xml) and click “Open”.

3.9.4 View license options

It is possible to view which license options that exist on a device.

1 Select the License tab.

2 Select a device.

3 In the bottom of the work area, the license options of the device are listed and 
whether the options are enabled or not.

3.9.5 Filter license options

It is possible to search and select devices which have same license options. The selected 
devices can be upgraded with additional licenses by exporting a product information file 
to the License Web (see Export Licensing information on page 35). The advantage to select 
devices with same license options is that additional licenses can be applied for the devices 
simultaneously.

1 Select the License tab.

2 Click “Advanced find“.

A dialog windows opens, see figure 28.

3 Under Device types, select device(s) .

4 Under Option filters, select the status of the license option(s) that shall be common 
for the selected devices.

• Ignore - show all devices independent of license options.
• Enabled - show devices with a certain license option enabled.
• Disabled - show devices with a certain license option disabled.

Figure 28. Filtering license options for devices.
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The search result is updated directly when selecting devices and license options. In 
addition, the icon is also displayed next to the Advanced find button to indicate that 
the search result is filtered.

When clicking Close, the filtered search result will still be displayed. When clicking Reset, 
the filter is removed and all devices are displayed.

3.9.6 Refresh

If a device is already registered in the WinPDM and a change of licenses has been done, 
the information needs to be updated. By doing a Refresh, the device license information in 
WinPDM is synchronized with the information in the license server and transferred to the 
device.

Note: This feature requires a connection to the license server.

1 Select the License tab.

2 Select device(s).

3 In the License menu, select "Refresh". The correct license is fetched from the 
license server, sent to the device and displayed in the Device Manager.

3.9.7 Remove Devices from the License View

This command removes devices from the licenses tab view.

1 Select the “licenses” tab.

2 Select the devices(s) that shall be removed from the list. The selected row(s) are 
highlighted.

3 In the license menu, select “Remove device” or right-click and select “Remove 
device”.

4 Click “Yes” in the Remove device dialogue.
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3.10 File management

This chapter covers File management for parameter definition files, software files, 
language files (.lng) for devices, and company phonebook files.

Import and export of templates and numbers are described in 3.11 Import and Export on 
page 45. Import of language files (.xml) for PDM are described in 2.2.5 Language settings 
for PDM on page 8.

The parameter definition file holds the definitions of all parameters for a specific version of 
a Number’s parameter set. Updated software and new parameter definition files for 
devices and Numbers can be added to the PDM, see 3.10.3 Import Parameter Definition 
files on page 39.

If there is a naming conflict when importing, a warning message is displayed.

3.10.1 Definition File Version – Parameter Version

Both definition files and device software include parameters and are indicated by a version 
number.

If a device associated to a Number is upgraded to a software supporting another 
parameter version than the stored Number, it does not always demand a new definition 
file. An old definition file can often be used, but if new parameters have been added in 
the new parameter version these parameters will not be editable. The release note will tell 
you if a new definition file is needed to match the new parameters.

Example

If a parameter version for the Number is 2.5, then a parameter definition file with a 
version between 2.0 and 2.5 is required.

3.10.2 Import a Package File

A package file may include different types of files, such as software files, parameter 
definition files and/or template files. If the package does not include a certain file, it can be 
imported seperately. See 3.10.3 Import Parameter Definition files on page 39, 3.10.4 
Import new Software for Devices on page 40, and/or 3.11.2 Import Templates on page 45.

1 In the File menu, select “File management”.

2 Select the Parameter definition tab or Software tab and click “Add”.

3 Select the package file (.pkg) to be imported and click “Open”.

The files included in the package are now imported. If needed, select the Parameter 
definition tab or Software tab to view the corresponding imported files (if any). 

If template(s) has been imported, it can be viewed by clicking “Close“ and then selecting 
the Template tab.

4 Click “Close”.
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3.10.3 Import Parameter Definition files

Note: Parameter definition files (.def) are mainly included in package files (.pkg) 
distributed by your supplier, see 3.10.2 Import a Package File on page 38.

1 In the File menu, select “File management”.

2 Select the Parameter definition tab and click “Add”.

3 Select the definition files to be imported and click “Open”.

Only files with a corresponding extension are shown, such as .def and .pkg.

4 Click “Close”.

Figure 29. File management window, Parameter definition tab
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3.10.4 Import new Software for Devices

Note: Software files (.bin) are mainly included in package files (.pkg) distributed by your 
supplier, see 3.10.2 Import a Package File on page 38.

1 In the File menu, select “File management”.

2 Select the Software tab and click “Add”.

3 Select the software files to be imported and click “Open”.

Only files with a corresponding extension are shown, such as .bin and .pkg.

4 Click “Close”.

Figure 30. File management window, Software tab
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3.10.5 Import Language files for Devices

Note: To select the language to be used in the PDM, see 2.2.5 Language settings for PDM 
on page 8.

For adding a new language to a device, a language file (.lng) distributed by your supplier 
must be imported to the PDM and then uploaded to the device.

1 In the File menu, select “File management”.

2 Select the "Language" tab and click “Add”.

3 Select the language files to be imported and click “Open”.

Only files with a corresponding extension are shown, such as .lng.

4 Click "Close".

5 To apply the language for a device, see 3.10.7 Upload a Language to Devices on 
page 43.

Figure 31. File management window, Language tab.
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3.10.6 Import Company Phonebook files

It is possible to import a company phonebook file for later use.

1 In the File menu, select “File management”.

2 Select the "Company Phonebook" tab and click “Add”.

3 Select the company phonebook files to be imported and click “Open”.

Only files with a corresponding extension are shown, such as .cpb.

4 Click “Close”.

Figure 32. File management window, Company Phonebook tab.
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3.10.7 Upload a Language to Devices

It is possible to upload a language to portable devices that support Language Upload.

1 Select the “Devices” tab.

2 Select the device(s) to upload a language to. It is possible to select several devices, 
but only devices of the same Device Type can be selected.

3 In the Device Menu, select "Upload Language...”.

Figure 33. The Upload language dialogue.

4 If needed; import the language file (.lng) to be used by clicking “Import...”, locate 
the file, and click “OK”.

5 In the Available files: drop-down list, select which language to upload.

6 Click "OK".

3.10.8 Upload a Company Phonebook

It is possible to upload a company phonebook to portable devices that support company 
phonebook upload.

1 Select the “Devices” tab.

2 Select the device(s) to upload a company phonebook to. It is possible to select 
several devices, but only devices of the same device type can be selected.

3 In the Device Menu, select "Upload company phonebook...”.

Figure 34. The Upload Company Phonebook dialogue.

4 Select which company phonebook to upload and click "OK".
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3.10.9 Upgrade a Device with new Software

It is possible to upgrade the software in a device.

1 Select the “Devices” tab.

2 Connect a device to the PC.

3 Select the device. It is possible to select several devices, but only devices of the same 
Device Type can be selected.

4 In the Device menu, select “Upgrade”.

Alternatively, right-click the device and choose “Upgrade”, double-click the desired 
device, or click the “Upgrade” button in the toolbar.

Figure 35. Upgrade dialogue

5 If the software to be used is not available, it needs to be imported. If so, click 
“Import...”. The Import software dialogue opens. Locate the file and click “Open”.

6 Select software to be used and click “OK”.

The software will be downloaded to the device. A progress bar in the Status column 
for the device shows the progress of the download.

To cancel the upgrade, click Device > “Cancel upgrade” in the menu. Alternatively, 
right-click the device in the device list and select “Cancel upgrade”.

The device will restart automatically after a successful download.

3.10.10 Delete Parameter Definition Files

1 In the File menu, select“File management”.

2 Select the Parameter definition tab.

3 Select the definition files to be deleted.

4 Click “Delete”. The Delete files dialogue appears.

5 Click “Yes”.

6 Click “Close”.

3.10.11 Delete Software

1 In the File menu, select “File management”.

2 Select the Software tab.

3 Select the software to be deleted.

4 Click “Delete”.

5 In the Delete files dialogue, click “Yes”

6 Click “Close”.

Figure 17. 
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3.10.12 Delete Language File for Devices

Note: This applies to language files (.lng) for devices. Language files (.xml) for PDM are 
not deleted.

1 In the File menu, select “File management”.

2 Select the Language tab.

3 Select the Language to be deleted.

4 Click “Delete”.

5 In the Delete files dialogue, click "Yes".

6 Click “Close”.

3.10.13 Delete Company Phonebook File

1 In the File menu, select “File management”.

2 Select the Company Phonebook tab.

3 Select the company phonebook file to be deleted.

4 Click “Delete”.

5 In the Delete files dialogue, click "Yes".

6 Click “Close”.

3.11 Import and Export

This section describes import and export of Numbers and templates.

Import and export of licensing information is described in 3.9 Licenses on page 34. Import 
and additional file handling of parameter definition files, software files and language files 
(.lng) for devices are described in 3.10 File management on page 38. Import of language 
files (.xml) for PDM are described in 2.2.5 Language settings for PDM on page 8.

The purpose of exporting and importing Numbers and templates is to be able to move 
Numbers and templates to another site or to use at a later time. It is also possible to move 
between PDM Windows Version and the Device Manager in IMS2.

The parameter configuration in Numbers can be exported to a file. This file can be used by 
the supplier to pre-program devices before delivery to the customer.

If there is a naming conflict when importing a template, the new template is imported and 
the old template is deleted. If there is a Number conflict when importing Numbers, an 
error message is displayed.

3.11.1 Import Numbers

Updated Number files may be distributed by your supplier.

1 In the File menu, select “Import” > “Numbers...”.

2 Select the Number files to be imported (*.xcp) and click “Open”.

3.11.2 Import Templates

Updated Template files may be distributed by your supplier.

1 In the File menu, select “Import” > “Templates...”.
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2 Select the Template files to be imported (*.tpl) and click “Open”.

3.11.3 Export Numbers to a File

It is possible to configure Numbers for a site and export the settings to a file. One or 
several Numbers can be selected. 

The exported file can then be used when producing new devices for the customer.

Only Numbers stored in the database can be exported.

There is no restriction on device type when exporting.

1 Select the “Numbers” tab.

2 Select the Number (or Numbers).

3 In the Number menu, select “Export”.

4 Enter a file name for the Numbers (.xcp) and where to save the file and click 
“Save”.

3.11.4 Export Templates

It is possible to export template files. One or several templates can be exported.

1 Select the “Templates” tab. The Templates view appears.

2 Select the template (or templates) to be exported.

3 In the Template menu, select “Export...”.

4 Enter a file name for the templates (.tpl) and where to save the file and click 
“Save”.

3.12 Other Settings

3.12.1 Autosave settings

Normally, when a device logs in, it is automatically saved in the PDM database and this is 
the default setting. The autosave function shall normally be enabled.

To disable automatic saving of new numbers:

1 In the Options menu, select “Preferences”.

2 In the Preferences dialogue, clear "Automatically save new numbers" and click 
"OK".
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4 Administration

4.1 Data Backup

All settings in the PDM, such as the configuration, the sites and the templates are stored 
as database files. It is recommended to do backups on a regular basis. Device software, 
definition files, templates, devices and Numbers including parameters are included in the 
backup.

4.1.1 Backup PDM Database Files

1 Close the PDM.

2 The database files are saved in a folder located in 
C:\Documents and Settings\<user name>\Application Data\Ascom\.

3 Copy the folder to, for example, a CD or a network drive.

4.1.2 Restore PDM Database Files

1 Close the PDM.

2 Retrieve the saved copy of the folder.

3 Copy the folder to 
C:\Documents and Settings\<user name>\Application Data\Ascom\.
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5 Uninstall the PDM

1 In the Windows Start menu, select your PDM application.

2 Select Uninstall.

3 Open the Control Panel > Add or Remove Programs.

4 Mark “Unite Host Router” and click “Add/Remove”.

Note: The Unite Host Router may be used for other programs on your computer.

5 Unite Host Router may have left configuration files. If you want to remove these 
files you can remove that folder.

6 Open the installation folder for the Unite Host Router, C:\Program Files\ASAB, and 
remove the “Unite Host Router” folder manually.

Figure 36. Selected elements in the installation folder.

Figure 18. 
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6 Troubleshooting

When troubleshooting the PDM, it is always a good idea to examine the log files, since 
they provide additional information that may prove useful. When reporting an error to 
your supplier, always include the appropriate log file.

Log files are stored under 
“C:\Documents and Settings\<user_name>\Application Data\Ascom\WinPDM\log\“. 
The log files are rotated every 10 MB and are time-stamped with 1 ms resolution.

The PDM does Not Start / Installation fails

To run the PDM, the computer must confirm to the requirements listed in 1.4 
Requirements on page 4. If you do not have the correct software versions installed, 
contact your system administrator.

To install the PDM, you must have administrator rights on the computer. Contact your 
system administrator if you are not able to install the PDM.

Firewall issues

Windows Firewall may alert you of “PMServer”, “CuspCsi”, “UspCsi”, “MwpCsi” and 
“CuspSerialCSI”. You can ignore these security alerts, it will not affect the PDM, but then 
the alerts will appear every time the PDM is started. A better way is to select “Continue 
blocking” or “Unblock”.

No Indication of connected Device

If a device does not show up in PDM, make sure the device is properly connected, or try 
disconnecting and reconnecting the device.

If a connected device does not show up as connected in the Devices view, the USB port or 
the RS232 port may not be configured correctly.

Open Windows Control Panel > System. Select the Hardware tab and then select Device 
Manager. If the device does not show up in the list (as a USB port or COM port controlled 
device depending on the portable model), check the connection and reinstall the drivers 
and/or software for the device.

Software in Device Not Recognised/Synchronization Fails

• A device might have software with a parameter set that is newer than the version 
recognised by the PDM. The PDM will then be unable to send parameters to the 
device. The  symbol (a red broken arrow) in the Parameters column for the selected 
device indicates that the synchronization between the device and the PDM was not 
successful. 

If this is the case, the PDM should be updated with new software and definition files 
provided by your local supplier. See 3.10.3 Import Parameter Definition files on page 
39.
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Software Upgrade Fails

Parameter Conflict

If a device is detected and the same Number has been used by another device in the 
system there will be a parameter conflict. A window dialog appears, asking the user to 
decide whether to use the Number settings in PDM or the number settings in the device.

One typical situation when this parameter conflict will occur is if a portable's hardware has 
been replaced.

If the replacement portable is first registered in the base station with the same Number as 
the damaged portable, and then connected to the PDM, the PDM will warn for a 
parameter conflict.

In this case, select “PDM” to transfer the phonebook of the damaged portable (located in 
PDM) to the new portable.

If “Device” is chosen in this situation, the phonebook belonging to the damaged portable 
and located in PDM will be deleted (and replaced with the empty phonebook in the 
replacement portable).

For more information about device replacement, see the Configuration Manual for 
respective device.

Figure 37. Figure 18. Parameter conflict dialogue.

Display shows Probable cause Action or comment

Aborted 1) Trying to downgrade a 
software of a handset that 
has been upgraded with a 
product license and/or 
functionality license.

2) The handset’s hardware 
does not support the 
software version you are 
trying to downgrade to.

1) The license(s) can be 
moved to an unlicensed 
handset (that is d62 Talker) 
using IMS2. 

2) Use another software 
version. Ask you supplier.

Figure 19. 
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Appendix A: PDM Keyboard Shortcuts

The following table shows the keyboard shortcuts that can be used in PDM.

A.1 General

A.2 Devices

A.3 Numbers

A.4 Templates

Shortcut Description

Ctrl + H Open the File management window.

Ctrl + Tab Switch tab

Alt + F4 Close the application

Shortcut Description

Ctrl + N Add a new device

Enter Upgrade the selected device(s)

Delete Delete the selected device(s)

Ctrl + F Find a device

Ctrl + Enter Open the Properties window for the selected device

Shortcut Description

Ctrl + N Add a new Number

Enter Edit the selected Number

Ctrl + C Copy the selected Number

F2 Rename the selected Number

Ctrl + S Save the selected Number to the database

Delete Delete the selected Number from the database

Ctrl + F Find a Number

Shortcut Description

Ctrl + N Add a new template

Enter Edit the selected template

Ctrl + C Copy the selected template

F2 Rename the selected template

Delete Delete the selected template

Ctrl + F Find a template
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A.5 licenses

Shortcut Description

Delete Delete the selected license(s)

Ctrl + F Find a license
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Appendix B: File types

In this appendix, the different file extensions that are used in PDM are explained. System 
files are not described.

File type Extension Description

Software file (devices) bin Software for devices

Company Phonebook file cpb Company Phonebook file for portable devices.

Parameter Definition file def Including all possible settings for a certain device 
type for a certain version.

Language file lng, or xml Language file for portable devices or PDM. 
Language file for PDM uses XML (eXtensible 
Markup Language.).

Package file pkg Archive that can include different file types such 
as parameter definition files (.def), software files 
(.bin) and template files (.tpl).

Site file ste Storage for site specific data. These files may not 
be edited manually.
Used only by PDM Windows Version.

Template file tpl Contains one or more exported templates.

Number file xcp Exported Numbers.

Product information file xml A file containing information needed for licensing 
and upgrade of a device.

License information file xml A file containing license keys for devices.
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